Welcome to the Jet Ski Club. Check in for Social Rides or post your own to meet new friends!
Carpark86.jpg
Paradise Point - Cook Island - Chinderra.png
IMG_0798.PNG
Jolly Roger Sponsors.png
800w JSTV on black 2A7FFF 30.png
Rebel.png
Livin-Logo-Red-1.jpg
BeachBar.jpg
DSC07240.jpg
 
           

Author Topic:  07 Kawasaki 250 ultra 'missing' under load  (Read 4400 times)

Offline Marish

  • Member
  • *****
  • Posts: 5
  • Total likes: 0
  • I Ride a: 2007 Kawasaki 250 ultra
  • My hometown waterway is: Lake Eildon/Port Phillip Bay
07 Kawasaki 250 ultra 'missing' under load
« on: March 20, 2017, 09:04:07 PM »
Hi guys,  my ski has a problem with hesitating or 'missing' under load at low-revs, despite being serviced and given the all-clear by JV Marine recently.  It hesitates a number of times, a little like I'm deliberately revving it, when given full throttle from rest until revs increase sufficiently,  then smoothes out nicely. JV tested it on its trailer in their dam but this was not enough to induce the issue and water-testing would have cost $240 more. From there it would still have been contingent on them diagnosing accurately and rectifying(?) Not sure if this is a common issue or whether anyone has experienced the same.  It otherwise runs well and has clocked 190hrs.

Cheers
Marish

Sent from my SM-G900I using The Jet Ski Club mobile app


Offline Jet Ski Club

  • Administrator
  • *****
  • Posts: 1045
  • Total likes: 31
    • Jet Ski Club
  • I Ride a: I ride anything that starts!
  • My hometown waterway is: Gold Coast, Australia
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #1 on: March 21, 2017, 10:37:53 AM »
Check it has new plugs of the right type and make sure all the leads are on properly.


It could be the TPS though.

See you on the water for some FUN!
Ph: +61 7 3151 2037
mandy@thejetski.club     
jsx17 


Offline Marish

  • Member
  • *****
  • Posts: 5
  • Total likes: 0
  • I Ride a: 2007 Kawasaki 250 ultra
  • My hometown waterway is: Lake Eildon/Port Phillip Bay
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #2 on: March 21, 2017, 09:36:15 PM »
Thanks-what's the TPS?

Sent from my SM-G900I using The Jet Ski Club mobile app


Offline Mandy

  • Woo Hoo
  • Member
  • *****
  • Posts: 3733
  • Total likes: 141
  • Fun First!
    • Jet Ski TV
  • I Ride a: I'll ride anything that starts :)
  • My hometown waterway is: Gold Coast, Australia
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #3 on: March 22, 2017, 07:40:51 AM »
http://www.ebay.com/itm/KAWASAKI-JETSKI-2008-ULTRA-250X-TPS-THROTTLE-SENSOR-21176-3762-/191957885911


You can bring it into the shop if it's not something your keen on doing your self :)



See you on the water for some FUN!
mandy@jetskitv.tv
Ph: +61 449 077 747
JSX18P 

Offline Marish

  • Member
  • *****
  • Posts: 5
  • Total likes: 0
  • I Ride a: 2007 Kawasaki 250 ultra
  • My hometown waterway is: Lake Eildon/Port Phillip Bay
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #4 on: March 27, 2017, 10:31:28 AM »
Thanks for this-much appreciated

Sent from my SM-G900I using The Jet Ski Club mobile app


Offline Marish

  • Member
  • *****
  • Posts: 5
  • Total likes: 0
  • I Ride a: 2007 Kawasaki 250 ultra
  • My hometown waterway is: Lake Eildon/Port Phillip Bay
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #5 on: April 06, 2017, 09:45:38 PM »
I think your shop is in QLD-is it something that's easy to fit myself?

Sent from my SM-G900I using The Jet Ski Club mobile app


Offline Mandy

  • Woo Hoo
  • Member
  • *****
  • Posts: 3733
  • Total likes: 141
  • Fun First!
    • Jet Ski TV
  • I Ride a: I'll ride anything that starts :)
  • My hometown waterway is: Gold Coast, Australia
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #6 on: April 07, 2017, 05:34:48 AM »
We can post you anything you need if you're sure about the diagnosis. Give us  acall if you like. 07 3151 2037

See you on the water for some FUN!
mandy@jetskitv.tv
Ph: +61 449 077 747
JSX18P 

Offline Marish

  • Member
  • *****
  • Posts: 5
  • Total likes: 0
  • I Ride a: 2007 Kawasaki 250 ultra
  • My hometown waterway is: Lake Eildon/Port Phillip Bay
Re: 07 Kawasaki 250 ultra 'missing' under load
« Reply #7 on: April 10, 2017, 07:58:22 AM »
Great thank you

Sent from my SM-G900I using The Jet Ski Club mobile app



 


 

Trending Topics

Paradise Point to Coochiemudlo - Sun 23rd Sept 8am Paradise Point by Jet Ski Club
[Yesterday at 09:24:52 PM]


Happy 10th Birthday Jet Ski Club! by Dirk
[September 17, 2018, 06:07:44 PM]


AJSA “Livin” Pirate Ride – Sunday 7th October 2018 by Mandy
[September 09, 2018, 11:56:56 AM]


Social ride around Straddie - Paradise Point Sat 18th Aug '18 at 8am by Mandy
[September 08, 2018, 05:52:02 PM]


2 banger session - 9am from Southport 11th aug '18 by Mandy
[September 07, 2018, 03:24:32 PM]


Paradise Point to Cook island, tweed river by DON B
[September 06, 2018, 08:29:26 PM]


AJSA 2018 AGM Notification by Mandy
[September 06, 2018, 04:07:22 PM]


Welcome to Spring! - Sat 1st Sept '18 by Mandy
[September 02, 2018, 10:14:15 AM]


New Members - Introduce yourselves and your Jet Ski here! by akad99
[August 30, 2018, 01:17:15 PM]


Training: Ski First Aid 25 Aug 18 by Mandy
[August 29, 2018, 07:08:58 PM]


Jet ski loosing power by CamGti155
[August 28, 2018, 10:28:56 AM]


BbTALKIN USA - Intercom headsets for Jet Skis! by Nigel
[August 26, 2018, 07:00:22 PM]


RIP Jet Ski Buddy! by johno
[August 25, 2018, 09:03:42 AM]


Cook Island & Tweed River - Sunday 15th July '18 8.30am departure by Mandy
[August 22, 2018, 06:36:07 PM]


“Hot Water” is set to begin filming Sept. 24. 18. by Jet Ski Club
[August 20, 2018, 08:25:43 AM]